Русское сообщество по скриптингу

Не запускается мод

Все вопросы по работе и настройке AMXX и его плагинов.

Модератор: liFe iS GoOD

Правила форума
1. Запрещено материться и оскорблять других участников форума.
2. Запрещен флуд, оффтоп, дабл постинг во всех разделах форума, кроме раздела "Болтовня".
3. Запрещено взламывать сайт/форум или наносить любой вред проекту.
4. Запрещено рекламировать другие ресурсы.
5. Запрещено создавать темы без информативного названия. Название темы должно отображать ее смысл.

В данном разделе форума разрешено создавать темы, касающие только вопросов по AMX Mod X и его плагинам.

Не запускается мод

Сообщение v1nno » 08 июл 2019, 20:52

Помогите в консоле выдает ошибку

L 07/08/2019 - 20:01:18: [AMXX] Run time error 10: native error (native "zp_register_zombie_class")
L 07/08/2019 - 20:01:18: [AMXX] [0] zwc_Zombie(v1.0.0).sma::plugin_precache (line 20)

Дебаг включен

Вот код плагина
Код: Выделить всё
#include <amxmodx> 
#include <zombieplague>

new const zclass_name[] = { "Оригинальный" } // Имя
new const zclass_info[] = { "[Баланс]" } // Описание
new const zclass_model[] = { "zombie_Source" } // Модель 
new const zclass_clawmodel[] = { "v_knife_zombie.mdl" } // Модель ножа 
const zclass_health = 3200 // Здоровье 
const zclass_speed = 240 // Скорость 
const Float:zclass_gravity = 0.88 // Гравитация 
const Float:zclass_knockback = 1.0 // Отдача

// Class IDs 
new g_zclassid1

// Классы зомби необходимо всегда регистрировать в plugin_precache 
public plugin_precache() 
{ 
   register_plugin
("zwc_Zombie", "1.0.0", "by V1NNO") 
   g_zclassid1 
= zp_register_zombie_class(zclass_name, zclass_info, zclass_model, zclass_clawmodel, zclass_health, zclass_speed, zclass_gravity, zclass_knockback) 
}

public zp_user_infected_post ( id, infector ) 
{ 
    if 
(zp_get_user_zombie_class(id) == g_zclassid1) 
   
{ 
     client_print
(id, print_chat, "Вы выбрали класс: Оригинальный") 
   
} 
}
Аватара пользователя
v1nno
 
Сообщения: 1
Зарегистрирован: 21 окт 2018, 21:58
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.
Опыт программирования: Меньше месяца
Языки программирования: Я ничего не знаю

Re: Не запускается мод

Сообщение thezolotoi » 23 авг 2019, 16:37

20 строку глянь g_zclassid1 = zp_register_zombie_class(zclass_name, zclass_info, zclass_model, zclass_clawmodel, zclass_health, zclass_speed, zclass_gravity, zclass_knockback)
Там ошибка
Аватара пользователя
thezolotoi
 
Сообщения: 5
Зарегистрирован: 17 янв 2019, 13:04
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.
Языки программирования: Я ничего не знаю


Вернуться в Вопросы по AMXX и его плагинам

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron