Русское сообщество по скриптингу

Небезопасный модуль

Все вопросы по скриптингу для Metamod, помощь в редактировании плагинов.
Правила форума
1. Запрещено материться и оскорблять других участников форума.
2. Запрещен флуд, оффтоп, дабл постинг во всех разделах форума, кроме раздела "Болтовня".
3. Запрещено взламывать сайт/форум или наносить любой вред проекту.
4. Запрещено рекламировать другие ресурсы.
5. Запрещено создавать темы без информативного названия. Название темы должно отображать ее смысл.

В данном разделе форума разрешено создавать темы, касающие только скриптинга для
Metamod.


Правила при создании новой темы:
1. При вставке кода плагина необходимо использовать тег [pawn], в противном случае, если тег [pawn] не отображает ваш код, можно использовать тег [code].
2. Любые изображения должны быть загружены, как вложения к вашему сообщению.
3. При описании проблемы или запросе на помощь в редактировании плагина обязательно выкладывайте исходник плагина.

Небезопасный модуль

Сообщение heka » 03 ноя 2013, 17:45

Компилю амхх, вроди бы все норм но в конце выдает ошибку:


Код: Выделить всё
1>helpers-x86.obj : error LNK2026: небезопасный модуль для образа SAFESEH.
1>     Создается библиотека .\jitrelease/amxmodx_mm.lib и объект .\jitrelease/amxmodx_mm.exp
1>C:\amxx\amxmodx-source\amxmodx\msvc10\JITRelease\amxmodx_mm.dll : fatal error LNK1281: Не удается создать образ SAFESEH.
========== Построение: успешно: 0, с ошибками: 1, без изменений: 0, пропущено: 0 ==========


Подскажите что не так :-[
Аватара пользователя
heka
 
Сообщения: 28
Зарегистрирован: 22 июл 2011, 22:51
Откуда: Запорожье
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.
Опыт программирования: Около года
Языки программирования: Counter Strike 1.6

Re: Небезопасный модуль

Сообщение Plrip » 03 ноя 2013, 18:35

Попробуй в дополнительных пар-х дописать
/SAFESEH:NO

Status:
Аватара пользователя
Plrip
Скриптер
 
Сообщения: 2908
Зарегистрирован: 03 дек 2011, 19:33
Откуда: Ukraine
Благодарил (а): 236 раз.
Поблагодарили: 599 раз.
Языки программирования: Counter-Strike 1.6
X-Ray
Killing-Floor [low]

Re: Небезопасный модуль

Сообщение heka » 04 ноя 2013, 17:22

Код: Выделить всё
1>------ Построение начато: проект: amxmodx_mm, Конфигурация: JITRelease Win32 ------
1>cl : командная строка warning D9002: пропуск неизвестного параметра "/SAFESEH:NO"
1>  amx.cpp
1>  amxcore.cpp
1>  amxdbg.cpp
1>  amxmod_compat.cpp
1>  amxmodx.cpp
1>  amxtime.cpp
1>  amxxfile.cpp
1>  amxxlog.cpp
1>  CCmd.cpp
1>  CEvent.cpp
1>  CFile.cpp
1>  CFlagManager.cpp
1>  CForward.cpp
1>  CLang.cpp
1>  CLogEvent.cpp
1>  CMenu.cpp
1>  CMisc.cpp
1>  CModule.cpp
1>  CPlugin.cpp
1>  CTask.cpp
1>  Создание кода...
1>  Компиляция...
1>  CVault.cpp
1>  debugger.cpp
1>  emsg.cpp
1>  fakemeta.cpp
1>  file.cpp
1>  float.cpp
1>  libraries.cpp
1>  md5.cpp
1>  messages.cpp
1>  meta_api.cpp
1>  modules.cpp
1>  natives.cpp
1>  newmenus.cpp
1>  nongpl_matches.cpp
1>  optimizer.cpp
1>  power.cpp
1>  sorting.cpp
1>  srvcmd.cpp
1>  strptime.cpp
1>  trie_natives.cpp
1>  Создание кода...
1>  Компиляция...
1>  util.cpp
1>  vault.cpp
1>  vector.cpp
1>  datastructs.cpp
1>  Создание кода...
1>cl : командная строка warning D9002: пропуск неизвестного параметра "/SAFESEH:NO"
1>  format.cpp
1>cl : командная строка warning D9002: пропуск неизвестного параметра "/SAFESEH:NO"
1>  string.cpp
1>helpers-x86.obj : error LNK2026: небезопасный модуль для образа SAFESEH.
1>     Создается библиотека .\jitrelease/amxmodx_mm.lib и объект .\jitrelease/amxmodx_mm.exp
1>C:\amxx\amxmodx-source\amxmodx\msvc10\JITRelease\amxmodx_mm.dll : fatal error LNK1281: Не удается создать образ SAFESEH.
========== Построение: успешно: 0, с ошибками: 1, без изменений: 0, пропущено: 0 ==========
Аватара пользователя
heka
 
Сообщения: 28
Зарегистрирован: 22 июл 2011, 22:51
Откуда: Запорожье
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.
Опыт программирования: Около года
Языки программирования: Counter Strike 1.6


Вернуться в Скриптинг

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1